QPR Knowledge Base 2015.1

Installation Components and Basic Requirements

Installation Components and Basic Requirements

Previous topic Next topic No directory for this topic  

Installation Components and Basic Requirements

Previous topic Next topic Topic directory requires JavaScript Mail us feedback on this topic!  

Basic requirements for a typical QPR 2015.1 installation are as follows:

Supported operating system

Database (the LocalDB database included in the standalone installations can be used for evaluation/demonstration purposes)

Web server software. (See Supported Web Servers. See configuration instructions for IIS at Appendix C - Web Server Configuration)

.NET Framework 2 (4.5 for additional components). On newer Windows versions, the .NET Framework 3.5 Windows feature which includes also earlier versions of .NET will be enabled at the beginning of the installation.

Supported web browser

Browser capable of rendering SVG or Microsoft Silverlight

Administrative privileges for installation

 

See more detailed system requirements in Appendix A - System Requirements and Recommendations.

 

Component

Additional Requirements

QPR User Management Client


QPR Metrics

Microsoft .NET Framework 2.0 or newer. This will be installed during the QPR Clients package installation if it is not found on the target machine.

QPR ProcessDesigner


QPR EnterpriseArchitect


QPR Add-In for Microsoft Office

32-bit version of Microsoft 2010 or 2013 (A separate installation package is available for 64-bit version of Microsoft Office 2010 and 2013.)

Microsoft .NET Framework 4.0
Visual Studio Tools for Office runtime 4.0

QPR Metrics Server


QPR BizArchitecture Server


QPR Foundation Server


QPR Web Application Server

Microsoft .NET Framework 2.0 or newer
Microsoft Silverlight or a browser capable of rendering SVG for viewing QPR Metrics content.

QPR Portal Web Contents

Web Server (Microsoft IIS, Apache)

QPR Web Services Foundation

Microsoft .NET Framework 4.5
Microsoft IIS 7.0 - 8.5 Web Server