QPR Knowledge Base 2015.1

Security Level for Executing QPR Scripts

Security Level for Executing QPR Scripts

Previous topic Next topic No directory for this topic  

Security Level for Executing QPR Scripts

Previous topic Next topic Topic directory requires JavaScript Mail us feedback on this topic!  

The ability to run QPR scripts can be defined by setting a security level for the scripts in the QPR_Clients.ini file. The setting for defining the security level is ClientScriptSecurity. The available levels are as follows:

 

Setting

Description

ClientScriptSecurity=0

Scripts cannot be run.

ClientScriptSecurity=1

Scripts can be run from the QPR Metrics or QPR Modeling clients using either the Run (QPR Metrics) or Open File Model (QPR Modeling Client) functionality. A confirmation is asked before executing the script.

ClientScriptSecurity=2

Scripts can be run from the QPR Metrics or QPR Modeling clients using either the Run (Metrics) or Open File Model (QPR Modeling Client) functionality. No confirmation is asked before running the script.

ClientScriptSecurity=3

In addition to running scripts from the clients, scripts can be run also by double-clicking a script file in the Windows explorer.

ClientScriptSecurity=4

As with ClientScriptSecurity=3. In addition, Integrated Windows Authentication is allowed.